WordPress

WordPress 技巧:禁用 WordPress 自动更新

随着 WordPress 的不断更新,官方早在3.7的版本中就添加了 WordPress 自动更新的功能,考虑到很多朋友在使用很早以前的 WordPress主题和插件,也许会造成后台的错误提示或者前台网页出错,所以周良这里分享一下禁用 WordPress 自动更新的几种方法。

第一种方法:通过 wp-config.php 屏蔽

代码如下:

// 禁用 WordPress 自动更新
define( 'WP_AUTO_UPDATE_CORE', false );

把这段代码加到 wp-config.php 文件中即可禁用WordPress的自动更新。

第二种:FTP 设置文件夹权限为不可写

如果你打算永远不升级你的 WordPress,那么我建议你可以在你的服务器中把WordPress文件夹给设置“不可写”权限,这样不仅可以禁用自动更新,还可以防止WordPress系统文件被恶意PHP代码感染。(至于这么设置文件夹权限,我推荐大家 Google 一下。)

微信扫一扫,分享到朋友圈

WordPress 技巧:禁用 WordPress 自动更新
46

你也可能喜欢

46 条评论

  1. 我的博客在SAE,很有必要关闭他

    1. @@TXisfine 你在SAE,那么你根本就没办法自动更新...SAE没有那个权限

      1. @周良 是的,但是看着他提示,心里不爽。。。

  2. 我的博客在SAE,很有必要关闭他

    1. @@TXisfine 你在SAE,那么你根本就没办法自动更新...SAE没有那个权限

      1. @周良 是的,但是看着他提示,心里不爽。。。

  3. 我博客有好多个, 很多有时忘了去手动更新, 这时自动更新就能起到不错的作用

    1. @aisin 不过我个人偏向于手动更新

  4. 我博客有好多个, 很多有时忘了去手动更新, 这时自动更新就能起到不错的作用

    1. @aisin 不过我个人偏向于手动更新

  5. 我的好像不会自动更新,奇怪,哈

    1. @zww.me vps文件权限、wp-config.php设置,都是可以影响的。我个人感觉这个自动更新就是鸡肋

      1. @周良 我的还是提示我升级,然后我点了升级才能升级。

  6. 我的好像不会自动更新,奇怪,哈

    1. @zww.me vps文件权限、wp-config.php设置,都是可以影响的。我个人感觉这个自动更新就是鸡肋

      1. @周良 我的还是提示我升级,然后我点了升级才能升级。

  7. 同事还可以禁用插件更新~加另外一行代码。

    1. @cy 有类似很多的,我到时候整理一下

  8. 同事还可以禁用插件更新~加另外一行代码。

    1. @cy 有类似很多的,我到时候整理一下

  9. 一直都是自动更新的路过

  10. 一直都是自动更新的路过

  11. 为了安全,肯定需要升级版,主题一般都兼容,不兼容的自己改一下

    1. @不给力的面条 这个的话。看个人了,有几个朋友的版本还是2.1的

      1. @周良 这么厉害,我记得我最早接触的是2.7 2.8版本

      2. @不给力的面条 我都已经忘记我第一个接触到的是什么版本了

  12. 为了安全,肯定需要升级版,主题一般都兼容,不兼容的自己改一下

    1. @不给力的面条 这个的话。看个人了,有几个朋友的版本还是2.1的

      1. @周良 这么厉害,我记得我最早接触的是2.7 2.8版本

      2. @不给力的面条 我都已经忘记我第一个接触到的是什么版本了

发表评论

您的电子邮件地址不会被公开。 必填项已用 * 标注

提示:点击验证后方可评论!

插入图片

关于周良粥凉

产品经理,现电商从业者;从事过互联网医疗与金融等行业。 / 写了 9 年独立博客,喜恶皆在字里行间。

分类

微信扫一扫

微信扫一扫